In short
- CVE-2021-25976 is a HIGH (CVSS 8.1) vulnerability affecting Piranha, piranha cms (dotnetfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.46%, higher than 39.7% of all vulnerabilities.
- Fix: update to 10.0-alpha1 or later.
| Package | Affected versions | Patched versions |
|---|
| Piranha NuGet | ≥ 4.0.0-alpha1, < 10.0-alpha1
| 10.0-alpha1
|
| piranha cms | = 4.0.0≥ 4.0.1, ≤ 9.2
| No fix yet |
Description
In PiranhaCMS, versions 4.0.0-alpha1 to 9.2.0 are vulnerable to cross-site request forgery (CSRF) when performing various actions supported by the management system, such as deleting a user, deleting a role, editing a post, deleting a media folder etc., when an ID is known.
NVD description
In PiranhaCMS, versions 4.0.0-alpha1 to 9.2.0 are vulnerable to cross-site request forgery (CSRF) when performing various actions supported by the management system, such as deleting a user, deleting a role, editing a post, deleting a media folder etc., when an ID is known.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free