In short
- CVE-2021-25977 is a MEDIUM (CVSS 5.4) vulnerability affecting Piranha, piranha cms (dotnetfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.65%, higher than 51.3% of all vulnerabilities.
- Fix: update to 9.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| Piranha NuGet | ≥ 7.0.0, < 9.2.0
| 9.2.0
|
| piranha cms | ≥ 7.0.0, ≤ 9.1.1
| No fix yet |
Description
In PiranhaCMS, versions 7.0.0 to 9.1.1 are vulnerable to stored XSS due to the page title improperly sanitized. By creating a page with a specially crafted page title, a low privileged user can trigger arbitrary JavaScript execution.
NVD description
In PiranhaCMS, versions 7.0.0 to 9.1.1 are vulnerable to stored XSS due to the page title improperly sanitized. By creating a page with a specially crafted page title, a low privileged user can trigger arbitrary JavaScript execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free