In short
- CVE-2021-25978 is a MEDIUM (CVSS 5.4) vulnerability affecting apostrophecms (apostrophecms), apostrophe.
- Chance of exploitation in the next 30 days (EPSS): 0.50%, higher than 42.8% of all vulnerabilities.
- Fix: update to 3.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| apostrophecms | ≥ 2.63.0, ≤ 3.3.1
| No fix yet |
| apostrophe npm | ≥ 2.63.0, < 3.4.0
| 3.4.0
|
Description
Apostrophe CMS versions between 2.63.0 to 3.3.1 are vulnerable to Stored XSS where an editor uploads an SVG file that contains malicious JavaScript onto the Images module, which triggers XSS once viewed.
NVD description
Apostrophe CMS versions between 2.63.0 to 3.3.1 are vulnerable to Stored XSS where an editor uploads an SVG file that contains malicious JavaScript onto the Images module, which triggers XSS once viewed.
More vulnerabilities in apostrophecms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free