In short
- CVE-2021-25979 is a CRITICAL (CVSS 9.8) vulnerability affecting apostrophecms (apostrophecms), apostrophe.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.6% of all vulnerabilities.
- Fix: update to 3.3.1, 3.4.0 or later.
Description
Apostrophe CMS versions between 2.63.0 to 3.3.1 affected by an insufficient session expiration vulnerability, which allows unauthenticated remote attackers to hijack recently logged-in users' sessions. As a mitigation for older releases the user account in question can be archived (3.x) or moved to the trash (2.x and earlier) which does disable the existing session.
NVD description
Apostrophe CMS versions prior to 3.3.1 did not invalidate existing login sessions when disabling a user account or changing the password, creating a situation in which a device compromised by a third party could not be locked out by those means. As a mitigation for older releases the user account in question can be archived (3.x) or moved to the trash (2.x and earlier) which does disable the existing session.
More vulnerabilities in apostrophecms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free