In short
- CVE-2021-26118 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.activemq:artemis-openwire-protocol, artemis (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.9%, higher than 90.2% of all vulnerabilities.
- Fix: update to 2.16.0 or later.
Description
While investigating ARTEMIS-2964 it was found that the creation of advisory messages in the OpenWire protocol head of Apache ActiveMQ Artemis 2.15.0 bypassed policy based access control for the entire session. Production of advisory messages was not subject to access control in error.
NVD description
While investigating ARTEMIS-2964 it was found that the creation of advisory messages in the OpenWire protocol head of Apache ActiveMQ Artemis 2.15.0 bypassed policy based access control for the entire session. Production of advisory messages was not subject to access control in error.
More vulnerabilities in org.apache.activemq:artemis-openwire-protocol
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free