In short
- CVE-2021-26505 is a CRITICAL (CVSS 9.8) vulnerability affecting hello.js (hello.js project), hellojs.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.9% of all vulnerabilities.
- Fix: update to 1.18.8 or later.
| Package | Affected versions | Patched versions |
|---|
| hello.js | = 1.18.6
| No fix yet |
| hellojs npm | < 1.18.8
| 1.18.8
|
Description
A prototype pollution vulnerability in MrSwitch hello.js prior to version 1.18.8 allows remote attackers to execute arbitrary code via hello.utils.extend function.
NVD description
Prototype pollution vulnerability in MrSwitch hello.js version 1.18.6, allows remote attackers to execute arbitrary code via hello.utils.extend function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free