In short
- CVE-2021-26544 is a MEDIUM (CVSS 5.4) vulnerability affecting org.apache.livy:livy-server, livy (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.6% of all vulnerabilities.
- Fix: update to 0.7.1-incubating or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.livy:livy-server Maven | ≥ 0.7.0-incubating, < 0.7.1-incubating
| 0.7.1-incubating
|
| livy | = 0.7.0-incubating
| No fix yet |
Description
Livy server version 0.7.0-incubating (only) is vulnerable to a cross site scripting issue in the session name. A malicious user could use this flaw to access logs and results of other users' sessions and run jobs with their privileges. This issue is fixed in Livy 0.7.1-incubating.
NVD description
Livy server version 0.7.0-incubating (only) is vulnerable to a cross site scripting issue in the session name. A malicious user could use this flaw to access logs and results of other users' sessions and run jobs with their privileges. This issue is fixed in Livy 0.7.1-incubating.
More vulnerabilities in org.apache.livy:livy-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free