In short
- CVE-2021-26697 is a MEDIUM (CVSS 5.3) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 4.6%, higher than 91.6% of all vulnerabilities.
- Fix: update to 2.0.1rc1, 2.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.0.0, < 2.0.1rc1< 2.0.1
| 2.0.1rc12.0.1
|
| airflow | = 2.0.0
| No fix yet |
Description
The lineage endpoint of the deprecated Experimental API was not protected by authentication in Airflow 2.0.0. This allowed unauthenticated users to hit that endpoint. This is low-severity issue as the attacker needs to be aware of certain parameters to pass to that endpoint and even after can just get some metadata about a DAG and a Task. This issue only affects Apache Airflow 2.0.0.
NVD description
The lineage endpoint of the deprecated Experimental API was not protected by authentication in Airflow 2.0.0. This allowed unauthenticated users to hit that endpoint. This is low-severity issue as the attacker needs to be aware of certain parameters to pass to that endpoint and even after can just get some metadata about a DAG and a Task. This issue affects Apache Airflow 2.0.0.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free