In short
- CVE-2021-26814 is a HIGH (CVSS 8.8) vulnerability affecting wazuh (wazuh), wazuh.
- Chance of exploitation in the next 30 days (EPSS): 8.7%, higher than 95.2% of all vulnerabilities.
- Fix: update to 4.0.4 or later.
| Package | Affected versions | Patched versions |
|---|
| wazuh | ≥ 4.0.0, ≤ 4.0.3
| No fix yet |
| wazuh npm | ≥ 4.0.0, < 4.0.4
| 4.0.4
|
Description
Wazuh API in Wazuh from 4.0.0 to 4.0.3 allows authenticated users to execute arbitrary code with administrative privileges via /manager/files URI. An authenticated user to the service may exploit incomplete input validation on the /manager/files API to inject arbitrary code within the API service script.
NVD description
Wazuh API in Wazuh from 4.0.0 to 4.0.3 allows authenticated users to execute arbitrary code with administrative privileges via /manager/files URI. An authenticated user to the service may exploit incomplete input validation on the /manager/files API to inject arbitrary code within the API service script.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free