In short
- CVE-2021-27919 is a MEDIUM (CVSS 5.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.6% of all vulnerabilities.
- Fix: update to 1.16.1 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.16.0-0, < 1.16.1
| 1.16.1
|
| go | ≥ 1.16.0, < 1.16.1
| 1.16.1
|
Description
Using Reader.Open on an archive containing a file with a path prefixed by "../" will cause a panic due to a stack overflow. If parsing user supplied archives, this may be used as a denial of service vector.
NVD description
archive/zip in Go 1.16.x before 1.16.1 allows attackers to cause a denial of service (panic) upon attempted use of the Reader.Open API for a ZIP archive in which ../ occurs at the beginning of any filename.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free