In short
- CVE-2021-27922 is a HIGH (CVSS 7.5) vulnerability affecting pillow, pillow (python).
- Chance of exploitation in the next 30 days (EPSS): 4.9%, higher than 92.0% of all vulnerabilities.
- Fix: update to 8.1.1, 8.1.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pillow PyPI | < 8.1.1< 8.1.2
| 8.1.18.1.2
|
| pillow | < 8.1.1
| 8.1.1
|
Description
Pillow before 8.1.2 allows attackers to cause a denial of service (memory consumption) because the reported size of a contained image is not properly checked for an ICNS container, and thus an attempted memory allocation can be very large.
NVD description
Pillow before 8.1.2 allows attackers to cause a denial of service (memory consumption) because the reported size of a contained image is not properly checked for an ICNS container, and thus an attempted memory allocation can be very large.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free