In short
- CVE-2021-28834 is a CRITICAL (CVSS 9.8) vulnerability affecting kramdown, kramdown (kramdown project).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 86.0% of all vulnerabilities.
- Fix: update to 2.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| kramdown RubyGems | ≥ 1.16.0, < 2.3.1
| 2.3.1
|
| kramdown | < 2.3.1
| 2.3.1
|
Description
Kramdown before 2.3.1 does not restrict Rouge formatters to the Rouge::Formatters namespace, and thus arbitrary classes can be instantiated.
NVD description
Kramdown before 2.3.1 does not restrict Rouge formatters to the Rouge::Formatters namespace, and thus arbitrary classes can be instantiated.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free