In short
- CVE-2021-29059 is a HIGH (CVSS 7.5) vulnerability affecting is-svg (is-svg project), is-svg.
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.6% of all vulnerabilities.
- Fix: update to 4.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| is-svg | ≥ 2.1.0, < 4.3.0
| 4.3.0
|
| is-svg npm | ≥ 2.1.0, < 4.3.0
| 4.3.0
|
Description
A vulnerability was discovered in IS-SVG version 4.3.1 and below where a Regular Expression Denial of Service (ReDOS) occurs if the application is provided and checks a crafted invalid SVG string.
NVD description
A vulnerability was discovered in IS-SVG version 2.1.0 to 4.2.2 and below where a Regular Expression Denial of Service (ReDOS) occurs if the application is provided and checks a crafted invalid SVG string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free