In short
- CVE-2021-29063 is a HIGH (CVSS 7.5) vulnerability affecting mpmath, mpmath (mpmath).
- Chance of exploitation in the next 30 days (EPSS): 4.2%, higher than 91.0% of all vulnerabilities.
- Fix: update to 1.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| mpmath PyPI | < 1.3.0
| 1.3.0
|
| mpmath | ≥ 1.0.0, ≤ 1.2.1
| No fix yet |
Description
A Regular Expression Denial of Service (ReDOS) vulnerability was discovered in Mpmath v1.0.0 when the mpmathify function is called.
NVD description
A Regular Expression Denial of Service (ReDOS) vulnerability was discovered in Mpmath v1.0.0 through v1.2.1 when the mpmathify function is called.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free