In short
- CVE-2021-29262 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.solr:solr-core, solr (apache).
- Chance of exploitation in the next 30 days (EPSS): 6.7%, higher than 93.9% of all vulnerabilities.
- Fix: update to 8.8.2 or later.
Description
When starting Apache Solr versions prior to 8.8.2, configured with the SaslZkACLProvider or VMParamsAllAndReadonlyDigestZkACLProvider and no existing security.json znode, if the optional read-only user is configured then Solr would not treat that node as a sensitive path and would allow it to be readable. Additionally, with any ZkACLProvider, if the security.json is already present, Solr will not automatically update the ACLs.
NVD description
When starting Apache Solr versions prior to 8.8.2, configured with the SaslZkACLProvider or VMParamsAllAndReadonlyDigestZkACLProvider and no existing security.json znode, if the optional read-only user is configured then Solr would not treat that node as a sensitive path and would allow it to be readable. Additionally, with any ZkACLProvider, if the security.json is already present, Solr will not automatically update the ACLs.
More vulnerabilities in org.apache.solr:solr-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free