In short
- CVE-2021-29421 is a HIGH (CVSS 7.5) vulnerability affecting pikepdf, pikepdf (pikepdf project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.1% of all vulnerabilities.
- Fix: update to 2.10.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pikepdf PyPI | ≥ 1.3.0, < 2.10.0
| 2.10.0
|
| pikepdf | ≥ 1.3.0, ≤ 2.9.2
| No fix yet |
Description
models/metadata.py in the pikepdf package 1.3.0 through 2.9.2 for Python allows XXE when parsing XMP metadata entries.
NVD description
models/metadata.py in the pikepdf package 1.3.0 through 2.9.2 for Python allows XXE when parsing XMP metadata entries.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free