In short
- CVE-2021-29621 is a MEDIUM (CVSS 5.3) vulnerability affecting flask-appbuilder, airflow (apache), flask-appbuilder (dpgaspar).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.9% of all vulnerabilities.
- Fix: update to 3.3.0 or later.
Description
Impact
User enumeration in database authentication in Flask-AppBuilder <= 3.2.3. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in.
Patches
Upgrade to 3.3.0
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is a development framework, built on top of Flask. User enumeration in database authentication in Flask-AppBuilder <= 3.2.3. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in. Upgrade to version 3.3.0 or higher to resolve.
More vulnerabilities in flask-appbuilder
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free