In short
- CVE-2021-30458 is a MEDIUM (CVSS 6.1) vulnerability affecting wikimedia/parsoid, parsoid (wikimedia).
- Chance of exploitation in the next 30 days (EPSS): 0.98%, higher than 62.1% of all vulnerabilities.
- Fix: update to 0.12.2, 0.11.1 or later.
| Package | Affected versions | Patched versions |
|---|
| wikimedia/parsoid Packagist | ≥ 0.12, < 0.12.2< 0.11.1
| 0.12.20.11.1
|
| parsoid | ≥ 0.12.0, < 0.12.2< 0.11.1
| 0.12.20.11.1
|
Description
An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.
NVD description
An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free