In short
- CVE-2021-3114 is a MEDIUM (CVSS 6.5) vulnerability affecting stdlib, go (golang).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 85.9% of all vulnerabilities.
- Fix: update to 1.15.7, 1.14.14 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.15.0-0, < 1.15.7< 1.14.14
| 1.15.71.14.14
|
| go | ≥ 1.15, < 1.15.7< 1.14.14
| 1.15.71.14.14
|
Description
The P224() Curve implementation can in rare circumstances generate incorrect outputs, including returning invalid points from ScalarMult.
NVD description
In Go before 1.14.14 and 1.15.x before 1.15.7, crypto/elliptic/p224.go can generate incorrect outputs, related to an underflow of the lowest limb during the final complete reduction in the P-224 field.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free