In short
- CVE-2021-3116 is a HIGH (CVSS 7.5) vulnerability affecting proxy-py, proxy.py (proxy.py project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.3% of all vulnerabilities.
- Fix: update to 2.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| proxy-py PyPI | < 2.3.1
| 2.3.1
|
| proxy.py | < 2.3.1
| 2.3.1
|
Description
before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or).
NVD description
before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free