In short
- CVE-2021-31407 is a HIGH (CVSS 7.5) vulnerability affecting com.vaadin:flow-server, flow (vaadin), vaadin (vaadin).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 83.9% of all vulnerabilities.
- Fix: update to 2.4.8, 6.0.1, 6.0.2, 14.4.10 or later.
| Package | Affected versions | Patched versions |
|---|
| com.vaadin:flow-server Maven | ≥ 1.2.0, < 2.4.8≥ 6.0.0, < 6.0.1
| 2.4.86.0.1
|
| flow | ≥ 1.2.0, < 2.4.8≥ 6.0.0, < 6.0.2
| 2.4.86.0.2
|
| vaadin | = 19.0.0≥ 12.0.0, < 14.4.10
| 14.4.10
|
Description
Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.
NVD description
Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.
More vulnerabilities in com.vaadin:flow-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free