In short
- CVE-2021-31408 is a HIGH (CVSS 7.1) vulnerability affecting com.vaadin:vaadin-bom, flow (vaadin), vaadin (vaadin).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.2% of all vulnerabilities.
- Fix: update to 19.0.4, 6.0.0, 6.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| com.vaadin:vaadin-bom Maven | ≥ 18.0.0, < 19.0.4
| 19.0.4
|
| flow | ≥ 5.0.0, < 6.0.0≥ 6.0.0, < 6.0.5
| 6.0.06.0.5
|
| vaadin | = 18.0.0≥ 19.0.0, < 19.0.4
| 19.0.4
|
Description
Authentication.logout() helper in com.vaadin:flow-client versions 5.0.0 prior to 6.0.0 (Vaadin 18), and 6.0.0 through 6.0.4 (Vaadin 19.0.0 through 19.0.3) uses incorrect HTTP method, which, in combination with Spring Security CSRF protection, allows local attackers to access Fusion endpoints after the user attempted to log out.
NVD description
Authentication.logout() helper in com.vaadin:flow-client versions 5.0.0 prior to 6.0.0 (Vaadin 18), and 6.0.0 through 6.0.4 (Vaadin 19.0.0 through 19.0.3) uses incorrect HTTP method, which, in combination with Spring Security CSRF protection, allows local attackers to access Fusion endpoints after the user attempted to log out.
More vulnerabilities in com.vaadin:vaadin-bom
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free