In short
- CVE-2021-31671 is a HIGH (CVSS 7.5) vulnerability affecting pgsync, pgsync (pgsync project).
- Chance of exploitation in the next 30 days (EPSS): 0.73%, higher than 54.5% of all vulnerabilities.
- Fix: update to 0.6.7 or later.
| Package | Affected versions | Patched versions |
|---|
| pgsync RubyGems | < 0.6.7
| 0.6.7
|
| pgsync | < 0.6.7
| 0.6.7
|
Description
pgsync before 0.6.7 is affected by Information Disclosure of sensitive information. Syncing the schema with the --schema-first and --schema-only options is mishandled. For example, the sslmode connection parameter may be lost, which means that SSL would not be used.
NVD description
pgsync before 0.6.7 is affected by Information Disclosure of sensitive information. Syncing the schema with the --schema-first and --schema-only options is mishandled. For example, the sslmode connection parameter may be lost, which means that SSL would not be used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free