In short
- CVE-2021-31800 is a CRITICAL (CVSS 9.8) vulnerability affecting impacket, impacket (secureauth).
- Chance of exploitation in the next 30 days (EPSS): 19.4%, higher than 97.4% of all vulnerabilities.
- Fix: update to 0.9.23 or later.
| Package | Affected versions | Patched versions |
|---|
| impacket PyPI | ≥ 0.9.10, < 0.9.23< 0.9.23
| 0.9.23
|
| impacket | ≤ 0.9.22
| No fix yet |
Description
Multiple path traversal vulnerabilities exist in smbserver.py in Impacket before 0.9.23. An attacker that connects to a running smbserver instance can list and write to arbitrary files via ../ directory traversal. This could potentially be abused to achieve arbitrary code execution by replacing /etc/shadow or an SSH authorized key.
NVD description
Multiple path traversal vulnerabilities exist in smbserver.py in Impacket through 0.9.22. An attacker that connects to a running smbserver instance can list and write to arbitrary files via ../ directory traversal. This could potentially be abused to achieve arbitrary code execution by replacing /etc/shadow or an SSH authorized key.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free