In short
- CVE-2021-32478 is a MEDIUM (CVSS 6.1) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.4% of all vulnerabilities.
- Fix: update to 3.10.4, 3.8.9, 3.9.7 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.10, < 3.10.4≥ 3.8, < 3.8.9≥ 3.9, < 3.9.7
| 3.10.43.8.93.9.7
|
| moodle | ≥ 3.10.0, < 3.10.4≥ 3.9.0, < 3.9.7< 3.8.9
| 3.10.43.9.73.8.9
|
Description
The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.
NVD description
The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free