| Package | Affected versions | Patched versions |
|---|---|---|
| jupyterlab | ≥ 2, < 2.2.10≥ 2.0.0a0, < 2.2.10≥ 2.3, < 2.3.2≥ 2.3.0a0, < 2.3.2≥ 3, < 3.0.17≥ 3.0.0a0, < 3.0.17≥ 3.1, < 3.1.4≥ 3.1.0a0, < 3.1.4< 1.2.21 | 2.2.102.3.23.0.173.1.41.2.21 |
| notebook | ≥ 6.0.0, < 6.4.1< 5.7.11 | 6.4.15.7.11 |
| jupyterlab | ≥ 2.0.0, < 2.2.10≥ 2.3.0, < 2.3.2≥ 3.0.0, < 3.0.17≥ 3.1.0, < 3.1.4< 1.2.21 | 2.2.102.3.23.0.173.1.41.2.21 |
Untrusted notebook can execute code on load. This is a remote code execution, but requires user action to open a notebook.
Patched in the following versions: 3.1.4, 3.0.17, 2.3.2, 2.2.10, 1.2.21.
OWASP Page on Restricting Form Submissions
If you have any questions or comments about this advisory, or vulnerabilities to report, please email our security list [email protected].
Credit: Guillaume Jeanne from Google
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free