In short
- CVE-2021-32805 is a MEDIUM (CVSS 6.1) vulnerability affecting flask-appbuilder, flask-appbuilder (dpgaspar).
- Chance of exploitation in the next 30 days (EPSS): 0.70%, higher than 53.2% of all vulnerabilities.
- Fix: update to 3.3.2 or later.
Description
Impact
If using Flask-AppBuilder OAuth, an attacker can share a carefully crafted URL with a trusted domain for an application built with Flask-AppBuilder, this URL can redirect a user to a malicious site. This is an open redirect vulnerability
Patches
Install Flask-AppBuilder 3.2.2 or above
Workarounds
Filter HTTP traffic containing ?next={next-site} where the next-site domain is different from the application you are protecting
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. In affected versions if using Flask-AppBuilder OAuth, an attacker can share a carefully crafted URL with a trusted domain for an application built with Flask-AppBuilder, this URL can redirect a user to a malicious site. This is an open redirect vulnerability. To resolve this issue upgrade to Flask-AppBuilder 3.2.2 or above. If upgrading is infeasible users may filter HTTP traffic containing `?next={next-site}` where the `next-site` domain is different from the application you are protecting as a workaround.
More vulnerabilities in flask-appbuilder
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free