In short
- CVE-2021-33473 is a CRITICAL (CVSS 9.1) vulnerability affecting dragonfly, dragonfly (dragonfly project).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.0% of all vulnerabilities.
- Fix: update to 1.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| dragonfly RubyGems | < 1.4.0
| 1.4.0
|
| dragonfly | = 1.3.0
| No fix yet |
Description
An argument injection vulnerability in Dragonfly Ruby Gem v1.3.0 allows attackers to read and write arbitrary files when the verify_url option is disabled. This vulnerability is exploited via a crafted URL.
NVD description
An argument injection vulnerability in Dragonfly Ruby Gem v1.3.0 allows attackers to read and write arbitrary files when the verify_url option is disabled. This vulnerability is exploited via a crafted URL.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free