In short
- CVE-2021-33575 is a CRITICAL (CVSS 9.8) vulnerability affecting ruby-jss, ruby-jss (pixar).
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.4% of all vulnerabilities.
- Fix: update to 1.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ruby-jss RubyGems | < 1.6.0
| 1.6.0
|
| ruby-jss | < 1.6.0
| 1.6.0
|
Description
The Pixar ruby-jss gem before 1.6.0 allows remote attackers to execute arbitrary code because of the Plist gem's documented behavior of using Marshal.load during XML document processing.
NVD description
The Pixar ruby-jss gem before 1.6.0 allows remote attackers to execute arbitrary code because of the Plist gem's documented behavior of using Marshal.load during XML document processing.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free