In short
- CVE-2021-3377 is a MEDIUM (CVSS 6.1) vulnerability affecting ansi up (ansi up project), ansi_up.
- Chance of exploitation in the next 30 days (EPSS): 8.0%, higher than 94.8% of all vulnerabilities.
- Fix: update to 5.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ansi up | < 5.0.0
| 5.0.0
|
| ansi_up npm | < 5.0.0
| 5.0.0
|
Description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
NVD description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free