In short
- CVE-2021-3427 is a MEDIUM (CVSS 6.1) vulnerability affecting deluge, deluge (deluge-torrent).
- Chance of exploitation in the next 30 days (EPSS): 0.96%, higher than 61.6% of all vulnerabilities.
- Fix: update to 2.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| deluge PyPI | < 2.1.0
| 2.1.0
|
| deluge | < 2.1.0
| 2.1.0
|
Description
The Deluge Web-UI is vulnerable to cross-site scripting through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.
NVD description
The Deluge Web-UI is vulnerable to XSS through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free