In short
- CVE-2021-34538 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.hive:hive, hive (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.2% of all vulnerabilities.
- Fix: update to 3.1.3 or later.
Description
Apache Hive before 3.1.3 CREATE and DROP function operations do not check for necessary authorization of involved entities in the query. It was found that an unauthorized user can manipulate an existing UDF without having the privileges to do so. This allowed unauthorized or underprivileged users to drop and recreate UDFs pointing them to new jars that could be potentially malicious.
NVD description
Apache Hive before 3.1.3 "CREATE" and "DROP" function operations does not check for necessary authorization of involved entities in the query. It was found that an unauthorized user can manipulate an existing UDF without having the privileges to do so. This allowed unauthorized or underprivileged users to drop and recreate UDFs pointing them to new jars that could be potentially malicious.
More vulnerabilities in org.apache.hive:hive
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free