In short
- CVE-2021-35440 is a MEDIUM (CVSS 6.1) vulnerability affecting smashing, smashing (smashing project).
- Chance of exploitation in the next 30 days (EPSS): 1.00%, higher than 62.9% of all vulnerabilities.
- Fix: update to 1.3.5 or later.
| Package | Affected versions | Patched versions |
|---|
| smashing RubyGems | < 1.3.5
| 1.3.5
|
| smashing | = 1.3.4
| No fix yet |
Description
Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim's computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL's for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.
NVD description
Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim's computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL's for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free