In short
- CVE-2021-35515 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.commons:commons-compress, commons compress (apache), banking digital experience (oracle).
- Chance of exploitation in the next 30 days (EPSS): 11.6%, higher than 96.0% of all vulnerabilities.
- Fix: update to 1.21 or later.
Description
When reading a specially crafted 7Z archive, the construction of the list of codecs that decompress an entry can result in an infinite loop. This could be used to mount a denial of service attack against services that use Compress' sevenz package.
NVD description
When reading a specially crafted 7Z archive, the construction of the list of codecs that decompress an entry can result in an infinite loop. This could be used to mount a denial of service attack against services that use Compress' sevenz package.
More vulnerabilities in org.apache.commons:commons-compress
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free