In short
- CVE-2021-35516 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.commons:commons-compress, commons compress (apache), banking digital experience (oracle).
- Chance of exploitation in the next 30 days (EPSS): 12.4%, higher than 96.2% of all vulnerabilities.
- Fix: update to 1.21 or later.
Description
When reading a specially crafted 7Z archive, Compress can be made to allocate large amounts of memory that finally leads to an out of memory error even for very small inputs. This could be used to mount a denial of service attack against services that use Compress' sevenz package.
NVD description
When reading a specially crafted 7Z archive, Compress can be made to allocate large amounts of memory that finally leads to an out of memory error even for very small inputs. This could be used to mount a denial of service attack against services that use Compress' sevenz package.
More vulnerabilities in org.apache.commons:commons-compress
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free