In short
- CVE-2021-36213 is a HIGH (CVSS 7.5) vulnerability affecting github.com/hashicorp/consul, consul (hashicorp).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.0% of all vulnerabilities.
- Fix: update to 1.10.1, 1.9.8 or later.
Description
In HashiCorp Consul before 1.10.1 (and Consul Enterprise), xds can generate a situation where a single L7 deny intention (with a default deny policy) results in an allow action.
NVD description
HashiCorp Consul and Consul Enterprise 1.9.0 through 1.10.0 default deny policy with a single L7 application-aware intention deny action cancels out, causing the intention to incorrectly fail open, allowing L4 traffic. Fixed in 1.9.8 and 1.10.1.
More vulnerabilities in github.com/hashicorp/consul
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free