In short
- CVE-2021-36716 is a HIGH (CVSS 7.5) vulnerability affecting is-email (segment), is-email.
- Chance of exploitation in the next 30 days (EPSS): 0.99%, higher than 62.7% of all vulnerabilities.
- Fix: update to 1.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| is-email | < 1.0.1
| 1.0.1
|
| is-email npm | < 1.0.1
| 1.0.1
|
Description
is-email helps validate an email address. A ReDoS (regular expression denial of service) flaw was found in the Segment is-email package before 1.0.1 for Node.js. An attacker that is able to provide crafted input to the isEmail(input) function may cause an application to consume an excessive amount of CPU.
NVD description
A ReDoS (regular expression denial of service) flaw was found in the Segment is-email package before 1.0.1 for Node.js. An attacker that is able to provide crafted input to the isEmail(input) function may cause an application to consume an excessive amount of CPU.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free