In short
- CVE-2021-39204 is a HIGH (CVSS 7.5) vulnerability affecting github.com/pomerium/pomerium, envoy (envoyproxy), pomerium (pomerium).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.7% of all vulnerabilities.
- Fix: update to 0.15.1, 0.14.8, 1.17.4, 1.18.4 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/pomerium/pomerium Go | ≥ 0.15.0, < 0.15.1< 0.14.8
| 0.15.10.14.8
|
| envoy | = 1.19.0≥ 1.17.0, < 1.17.4≥ 1.18.0, < 1.18.4≤ 1.16.4
| 1.17.41.18.4
|
| pomerium | = 0.15.0< 0.14.8
| 0.14.8
|
Description
Envoy, which Pomerium is based on, incorrectly handles resetting of HTTP/2 streams with excessive complexity. This can lead to high CPU utilization when a large number of streams are reset.
Impact
This can result in a DoS condition.
Patches
Pomerium versions 0.14.8 and 0.15.1 contain an upgraded envoy binary with this vulnerability patched.
Workarounds
N/A
References
envoy GSA
envoy CVE
envoy announcement
For more information
If you have any questions or comments about this advisory:
NVD description
Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, incorrectly handles resetting of HTTP/2 streams with excessive complexity. This can lead to high CPU utilization when a large number of streams are reset. This can result in a DoS condition. Pomerium versions 0.14.8 and 0.15.1 contain an upgraded envoy binary with this vulnerability patched.
More vulnerabilities in github.com/pomerium/pomerium
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free