In short
- CVE-2021-39371 is a HIGH (CVSS 7.5) vulnerability affecting pywps, owslib (osgeo), pywps (osgeo).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.7% of all vulnerabilities.
- Fix: update to 4.5.0, 4.4.5 or later.
| Package | Affected versions | Patched versions |
|---|
| pywps PyPI | < 4.5.0
| 4.5.0
|
| owslib | = 0.24.1
| No fix yet |
| pywps | < 4.4.5
| 4.4.5
|
Description
An XML external entity (XXE) injection in PyWPS before 4.5.0 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
NVD description
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free