In short
- CVE-2021-3943 is a CRITICAL (CVSS 9.8) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.0% of all vulnerabilities.
- Fix: update to 3.10.8, 3.11.4, 3.9.11 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.10, < 3.10.8≥ 3.11, < 3.11.4≥ 3.9, < 3.9.11
| 3.10.83.11.43.9.11
|
| moodle | ≥ 3.10.0, ≤ 3.10.7≥ 3.11.0, ≤ 3.11.3≥ 3.9.0, ≤ 3.9.10
| No fix yet |
Description
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A remote code execution risk when restoring backup files was identified.
NVD description
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A remote code execution risk when restoring backup files was identified.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free