In short
- CVE-2021-39880 is a MEDIUM (CVSS 6.5) vulnerability affecting apollo_upload_server, gitlab (gitlab).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.5% of all vulnerabilities.
- Fix: update to 2.1.0, 14.0.9, 14.1.4, 14.2.2 or later.
| Package | Affected versions | Patched versions |
|---|
| apollo_upload_server RubyGems | < 2.1.0
| 2.1.0
|
| gitlab | ≥ 11.9.0, < 14.0.9≥ 14.1.0, < 14.1.4≥ 14.2.0, < 14.2.2> 11.9.0, < 14.0.9> 14.1.0, < 14.1.4
| 14.0.914.1.414.2.2
|
Description
A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE version 11.11 and above allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.
NVD description
A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free