In short
- CVE-2021-40146 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.any23:apache-any23, any23 (apache).
- Chance of exploitation in the next 30 days (EPSS): 5.7%, higher than 93.0% of all vulnerabilities.
- Fix: update to 2.5 or later.
Description
A Remote Code Execution (RCE) vulnerability was discovered in the Any23 YAMLExtractor.java file and is known to affect Any23 versions < 2.5. RCE vulnerabilities allow a malicious actor to execute any code of their choice on a remote machine over LAN, WAN, or internet. RCE belongs to the broader class of arbitrary code execution (ACE) vulnerabilities.
NVD description
A Remote Code Execution (RCE) vulnerability was discovered in the Any23 YAMLExtractor.java file and is known to affect Any23 versions < 2.5. RCE vulnerabilities allow a malicious actor to execute any code of their choice on a remote machine over LAN, WAN, or internet. RCE belongs to the broader class of arbitrary code execution (ACE) vulnerabilities.
More vulnerabilities in org.apache.any23:apache-any23
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free