In short
- CVE-2021-40525 is a CRITICAL (CVSS 9.1) vulnerability affecting org.apache.james:james-server, james (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.8%, higher than 90.1% of all vulnerabilities.
- Fix: update to 3.6.1, 3.6.2 or later.
Description
Apache James ManagedSieve implementation alongside with the file storage for sieve scripts is vulnerable to path traversal, allowing reading and writing any file. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade. Distributed and Cassandra based products are also not impacted.
NVD description
Apache James ManagedSieve implementation alongside with the file storage for sieve scripts is vulnerable to path traversal, allowing reading and writing any file. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade. Distributed and Cassandra based products are also not impacted.
More vulnerabilities in org.apache.james:james-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free