In short
- CVE-2021-40720 is a CRITICAL (CVSS 9.8) vulnerability affecting ops-cli, ops-cli (adobe).
- Chance of exploitation in the next 30 days (EPSS): 9.5%, higher than 95.5% of all vulnerabilities.
- Fix: update to 2.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ops-cli PyPI | < 2.0.5
| 2.0.5
|
| ops-cli | < 2.0.5
| 2.0.5
|
Description
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
NVD description
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free