In short
- CVE-2021-41122 is a MEDIUM (CVSS 4.3) vulnerability affecting vyper, vyper (vyperlang).
- Chance of exploitation in the next 30 days (EPSS): 0.80%, higher than 56.7% of all vulnerabilities.
- Fix: update to 0.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vyper PyPI | < 0.3.0
| 0.3.0
|
| vyper | < 0.3.0
| 0.3.0
|
Description
Impact
The following code does not properly validate that its input is in bounds.
@external
def foo(x: decimal) -> decimal:
return x
Patches
0.3.0 / #2447
Workarounds
Don't use decimal args
NVD description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free