In short
- CVE-2021-41230 is a HIGH (CVSS 8.8) vulnerability affecting github.com/pomerium/pomerium, pomerium (pomerium).
- Chance of exploitation in the next 30 days (EPSS): 0.86%, higher than 58.5% of all vulnerabilities.
- Fix: update to 0.15.6 or later.
Description
Impact
Changes to the OIDC claims of a user after initial login are not reflected in policy evaluation when using allowed_idp_claims as part of policy. If using allowed_idp_claims and a user's claims are changed, Pomerium can make incorrect authorization decisions.
Patches
v0.15.6
Workarounds
- Clear data on
databroker service by clearing redis or restarting the in-memory databroker to force claims to be updated
References
https://github.com/pomerium/pomerium/pull/2724
For more information
If you have any questions or comments about this advisory:
NVD description
Pomerium is an open source identity-aware access proxy. In affected versions changes to the OIDC claims of a user after initial login are not reflected in policy evaluation when using `allowed_idp_claims` as part of policy. If using `allowed_idp_claims` and a user's claims are changed, Pomerium can make incorrect authorization decisions. This issue has been resolved in v0.15.6. For users unable to upgrade clear data on `databroker` service by clearing redis or restarting the in-memory databroker to force claims to be updated.
More vulnerabilities in github.com/pomerium/pomerium
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free