In short
- CVE-2021-41247 is a HIGH (CVSS 7.5) vulnerability affecting jupyterhub, jupyterhub (jupyter).
- Chance of exploitation in the next 30 days (EPSS): 0.80%, higher than 56.8% of all vulnerabilities.
- Fix: update to 1.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| jupyterhub PyPI | ≥ 1.0.0, < 1.5.0
| 1.5.0
|
| jupyterhub | ≥ 1.0.0, < 1.5.0
| 1.5.0
|
Description
Impact
Users of JupyterLab with JupyterHub who have multiple JupyterLab tabs open in the same browser session, may see incomplete logout from the single-user server, as fresh credentials (for the single-user server only, not the Hub) reinstated after logout, if another active JupyterLab session is open while the logout takes place.
Patches
Upgrade to JupyterHub 1.5. For distributed deployments, it is jupyterhub in the user environment that needs patching. There are no patches necessary in the Hub environment.
Workarounds
The only workaround is to make sure that only one JupyterLab tab is open when you log out.
NVD description
JupyterHub is an open source multi-user server for Jupyter notebooks. In affected versions users who have multiple JupyterLab tabs open in the same browser session, may see incomplete logout from the single-user server, as fresh credentials (for the single-user server only, not the Hub) reinstated after logout, if another active JupyterLab session is open while the logout takes place. Upgrade to JupyterHub 1.5. For distributed deployments, it is jupyterhub in the _user_ environment that needs patching. There are no patches necessary in the Hub environment. The only workaround is to make sure that only one JupyterLab tab is open when you log out.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free