In short
- CVE-2021-41263 is a HIGH (CVSS 8.8) vulnerability affecting rails_multisite, rails multisite (discourse).
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.2% of all vulnerabilities.
- Fix: update to 4.0.0 or later.
Description
Impact
This vulnerability impacts any Rails applications using rails_multisite alongside Rails' signed/encrypted cookies. Depending on how the application makes use of these cookies, it may be possible for an attacker to re-use cookies on different 'sites' within a multi-site Rails application.
Patches
The issue has been patched in v4 of the rails_multisite gem. Note that this upgrade will invalidate all previous signed/encrypted cookies. The impact of this invalidation will vary based on the application architecture.
NVD description
rails_multisite provides multi-db support for Rails applications. In affected versions this vulnerability impacts any Rails applications using `rails_multisite` alongside Rails' signed/encrypted cookies. Depending on how the application makes use of these cookies, it may be possible for an attacker to re-use cookies on different 'sites' within a multi-site Rails application. The issue has been patched in v4 of the `rails_multisite` gem. Note that this upgrade will invalidate all previous signed/encrypted cookies. The impact of this invalidation will vary based on the application architecture.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free