In short
- CVE-2021-41500 is a HIGH (CVSS 7.5) vulnerability affecting cvxopt, cvxopt (cvxopt project).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.1% of all vulnerabilities.
- Fix: update to 1.2.7 or later.
| Package | Affected versions | Patched versions |
|---|
| cvxopt PyPI | < 1.2.7
| 1.2.7
|
| cvxopt | ≤ 1.2.6
| No fix yet |
Description
Incomplete string comparison vulnerability exits in cvxopt.org cvxop <= 1.2.6 in APIs (cvxopt.cholmod.diag, cvxopt.cholmod.getfactor, cvxopt.cholmod.solve, cvxopt.cholmod.spsolve), which allows attackers to conduct Denial of Service attacks by construct fake Capsule objects.
NVD description
Incomplete string comparison vulnerability exits in cvxopt.org cvxop <= 1.2.6 in APIs (cvxopt.cholmod.diag, cvxopt.cholmod.getfactor, cvxopt.cholmod.solve, cvxopt.cholmod.spsolve), which allows attackers to conduct Denial of Service attacks by construct fake Capsule objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free