In short
- CVE-2021-42771 is a HIGH (CVSS 7.8) vulnerability affecting babel, babel (pocoo).
- Chance of exploitation in the next 30 days (EPSS): 0.77%, higher than 55.7% of all vulnerabilities.
- Fix: update to 2.9.1 or later.
| Package | Affected versions | Patched versions |
|---|
| babel PyPI | < 2.9.1
| 2.9.1
|
| babel | < 2.9.1
| 2.9.1
|
Description
Babel.Locale in Babel before 2.9.1 allows attackers to load arbitrary locale .dat files (containing serialized Python objects) via directory traversal, leading to code execution.
NVD description
Babel.Locale in Babel before 2.9.1 allows attackers to load arbitrary locale .dat files (containing serialized Python objects) via directory traversal, leading to code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free